Installing Code Composer Studio V5.5 and building projects

1. Installing CCSVS5.5 on Windows 7

Choose the following options for a minimal installation for DSK6713 board (spectrum Digital)
CCS install folder E:\ti (or any other drive , we have used E: drive)

Setup Type: Custom

Processor Support: C6000 Single Core DSPs

Select Components :Select all options (Base installation)

Select Emulators:Spectrum Digital Emulators

2. Install Board support libraries

Download the board support library (BSL), available at
http://c6000.spectrumdigital.com/dsk6713/

Under the option Board Supprt Library and code examples.

extract the zip file dsk6713revc_files and copy the folder CCStudio to E:\\DSK6713

3. Install chip support libraries
Download the board support library (BSL), available at http://www.ti.com/tool/sprc090
Extract the file sprc090 and install the CSL at E:\C6xCSL

4. Download the Support files

Download the updated Support files provided with the text Digital Signal Processing and
Applications with the TMS320C6713 and TMS320C6416 DSK (second edition) by Rulph
Chassaing and Donald Reay from this location

Support files (The files are the property of the above book authors) TI forum post Link 2
Extract the Support files to EA\DSK6713\C6713

5. Plug in the DSK and start up CCS v5
Connect the DSK6713 to the PC using USB cable and power up the board
you will see "Spectrum Digital TMS320C6713 DSK" listed as an installed device

6. Target Configuration

Double click the CCS icon from the desktop to launch CCS

In CCS v5, go to Window > Show View >Target Configurations

Right click on the "User Defined" folder in the target configurations panel and select New
Configuration

Name the configuration DSK6713.ccxml and click Finish.A new screen launches.

In the connection pulldown menu, select Spectrum Digital DSK-EVM-eZdsp onboard USB
Emulator. In the device selector, select DSK6713. Click Save.

Now expand the User Defined" target configurations folder by clicking on the little triangle next
to the folder. You should see the new DSK6713.ccxml target configuration in there. Right click
on it and select "Launch Selected Configuration".

If you get an error, then either CCS v5 wasn't installed correctly or you haven't set up the target
configuration correctly.

Now click on "Run->Connect Target"

The message "GEL StartUp Complete" in the Console means that CCS v35 is successfully talking
with the DSK.

You are now ready to build your project using CCS V5.5



Steps to Build a project in Code Composer Studio version 5.5

Launch CCC >Click on "File->New->CCS Project

2. CCS Project

Type in a project name
Output type : Executable
Device : Family : C6000
Variant : DSK6713
Connection: Spectrum Digital DSK-EVM eZDSP onboard USB emulator
Project templates and examples, select "Empty Project" and then click "Finish".

v+ New CCS Project o B[]
CCS Project — e

Create a new CCS Project. :_" E

Project name: | tes

Output type: | Executable - l

[¥] Use default location

Ehdsp labh\tes Browse...
Device
Family: | C6000 -
Variant: <select or type filter text> ~ |DSK&T13 - ]
Connection: ’Spectrur‘n Digital DSK-EVM-eZdsp onboard USE Emulator v]

b Advanced settings

= Project templates and examples

type filter text Creates an empty project fully initialized =
for the selected device,

4 [=) Empty Projects -
|5 Empty Project [ |
|55r Empty Project (with main.c) E|
|55r Empty Assembly-only Project |
[& Empty RTSC Project

4 ||=| Basic Examples

= i1 AR 1

@ < Back Next > Finish | | Cancel




The project window launches and will look as shown in the figures below

File Edit View MNavigate Project Run Scripts Window Help
E % CCSDebug 17
= =]
4 |l test [Active - Debug]
3 Includes
4 = targetConfigs
DSKBT13. coxml [Active]
readme.txt
El console @4}|ZEEE|?:|FJE'F3':E
CDT Build Console [test]
4 LI 3 -
L lieemed L Siew

Config

File Edit View Mavigate Project Run Scripts Window Help L

CO~-HR S~ i~ £~ v E % CCSDebug (B3~
T projectiplorr 33| = 0|2} pskamacomiyE3) =0
= o= . ~11F
. Basic il
4 12 test [Active - Debug]
B Includes General Setup
a (= targetConfigs This section describes the general configuration about the target. |
it Connection [ Spectrum Digital DSK-EVM-eZdsp onboard USE Emulator v
readme. et
Board or Device  type filter text
DSKG416 o I
D5KG455
D5KGT13
DSKTCIa482 i
EVMB413
=1 _riimaca1e 4
1 11 | ,

Basic‘ Advancedl Source|

EConsoleSSI {}{?|ﬁgﬁ|§=‘n|ﬂ'ﬂvrﬁ'=5

CDT Build Console [test]

4 i | r -

[ Licensed




4.Add source program to the project

File> New > Source file

Source file: Give the name of the source file as “myprog.c” (Don’t forget the extension .c)

Template : Default C++ source template

o

Edit View Navigate Project Run Scripts Window Help ]
New Alt+ShifteN b | [ CCS Project =1
Open File... 5 Project... =5
Close Ctrl+W | [¢] SourceFile ~
Close All Ctrl+Shift+ W m Header File
Save Ctrl+S ?: C=
e A [ File from Template
Save Al Curteshiftes | S | Folder for_—

e |4/ Target Configuration File

DSP/BIOS v5.x Configuraticn File
R |&  RTSC Configuration File
# Rename.. F2
=
&) Refiesh g5 | Other. Ctrl+N
DSKTCIEEST
Convert Line Delimiters To 3
] EVMB413
: 1 runazain 5

Print... Ctrl+P 3 D

Switch Workspace 3 (E‘

Restart S uE Mk fB-r9-°0
£y Import... t] =
ey Export..

Properties Alt+Enter

1 DSKB713.caxml [test/targetConfigs] -

2 Vectors_intr.asm [waveform]

713.coml

3 waveform [waveform]

4 Vectors_intr.obj [waveform/Debug]

it m g gy LLEI1AM

< MR nms

_File Edit View Mavigate Project Run  Scripts Window Help
M-HR N B P - [ % CCSDebug [H17
(25 Project Explorer &3 =8 M =8
Il 1/* -
s 2 = 2 * test.c
a = test [Active - Debug] 3 =+
b [l Includes 4 * Created on: Qct 2, 2015 =
[ (= targetConfigs - Author: Monteirg
3 E] test.c & 1_‘*;
12| 7#include "DSKE713_AIC23.h" //godeg support
8 Uint32 fs=DSK6713_AIC23_FREQ 8KHZ; //set sampling rate
9 #define DSKE713_AIC23 INPUT _MIC @x8815 V&S
10 #define DSK6713 AIC23_INPUT_LINE @x@ell
11 Uintl6 inputsource=DSKE713 AIC23 INPUT_LINE; // select LIF
12
13 // * Define global variables here *
14
15 short sine_table[8] = {@,707,1000,707,0,-707,-1000,-707};
16 short gain = 1@;
17int i = B;
13 %
< | ] | v
EConsoleE@] Gﬁlﬂﬁﬁ@ulrjﬂvrﬁ':ﬁ
CDT Build Console [test]
< m r -
i * Licensed Writable Srmart Insert 35:2




Add the required support files from E:\DSK6713\C6713\Support
Add the files : C6713dsk.cmd  c6713dskinit.c  c¢6713dskinit.h dsk6713_aic23.h
Vectors_intr.asm or Vectors_poll.asm

++ CCS Edit - test/test.c - Code Composer Studio EI@
File Edit View Mavigate Project Run Scripts Window Help
Ci-BE & % #-iF LoD B % CCS Debug (B
[} Project Explorer 23 = B || [g *test.c 2 =08
e = " 5 - »
=l = 7 #include "DSKE713_AIC23.h //gedec support
a[[= test [Active - Debug] & Uint32 fs=DSK6713_AIC23_FREQ_BKHZ; //set sampling rate
!

9 #define DSK6713_AIC23_INPUT_MIC @x@els

> [t Includes E
tarGaCERE 10 #define DSK6713_AIC23_INPUT_LINE @x8@11

4 @ targetConhigs 11Uintl6 inputsource=DSK6713_AIC23_INPUT_LINE;  // selsct LIN |
[#] DSKB713.coxml [Active] 12
[ readme.tdt 13 // * Define global variables here *

> | g CBT713dsk.cmd 14

, [8 cET3dskinit.c 15 short sine_table[8] = {@,707,1080,767,8,-707,-1000,-707};
! 16 short gain = 18;

> [n] C6713dskinit.h 17int i = @:
- [0 dsk6713_aic23.h 18
o [ testc 19 interrupt void c_inti11() //interrupt service routine
> Vectors_intr.asm 20 {
21 output_sample(gain*sine_table[i]);
27 4= i+1;
23if(i »= 8)i=e0;
24 return;

& void main() // Main Program

/ write your main program below

DSK, cedec, McBSP &

g | i . ¥

i Licensed = foct

Right click on Project name in the Project Explorer > Show Build Settings > Build > C6000
Compiler > Processor Options >Target processor version and set its value to ''6713" (no
quotes)

'+ Properties for test :@

type filter text Processor Options el v

General
4 Build
a C6000 Compiler : |Debug [ Active ] '] ’Manage Configurations...

Processor Options
Optimization

Debug Options
Include Options
Performance Advisor | endian code [See 'General' page to edit] (--big_endian, -me)

wwersion (--silicon_version, -mv) 6?13|

> Advanced Options coffabi
» 6000 Linker

.

?) ing
C) Show advanced settings OK ] ’ Cancel




Include required header files and libraries in the project
Build > C6000 Compiler >Include options / Add dir to # include search and path click Add
file

'+ Properties for test = l@
type filter text Include Options CIBAEDES 82
General
4 Build =
4 C6000 Compiler Cenfiguration: ’Debug [ Active ] '] ’Manage Configurations...]

Processor Options
Optimization

Debug Options -
Add dir to #include search path (--include_path, -I) &l 8 5l L

"${CG_TOOL_ROOTYinclude” Ackda

Include Options

Performance Advisor
» Advanced Options
> 6000 Linker

m

Specify a preinclude file (--preinclude) L=

® Show advanced settings [ 0K ] ’ Cancel ]

Add the following paths or browse and locate using the file system option
E:\DSK6713\CCStudio\c6000\dsk6713\include

E:\C6xCSL\include

(Make the necessary changes in the path depending on where you have the above folders)

'+ Properties for test = ’@
type filter text Include Options iz
General B
4 Build =
4 C6000 Compiler Cenfiguration: ’Debug [ Active ] '] ’Manage Configurations...]

Processor Options
Optimization

Debug Opticns -
Add dir to #include search path (--include path, -) 2 8 3853

Include Options— &
Performance 4 ¥ Add director path [

> Advanced Opti
> 6000 Linker

Directory:
EADSKBT1NCCStudio\c60000dsk6713Ninclude

m

[ OK ] [ Cancel ] [ Workspace... ] [ File system... ]

Specify a preinclude file (--preinclude] AR R

@ Show advanced settings [ 0K ] ’ Cancel




f_‘:- Properties for test 'EI@ L

| type filter text | | Include Options Gw v w [
General
4 Build =

a 6000 Compiler Configuration: ’Debug [ Active ] v] ’Manage Configurations...]
Processor Options
Optimization
Debug Options - -
Include Options Add dir to #include search path (--include_path, -I) [E TR
Performance Advisor "S$CG_TOOL_ROOTYinclude”

"ENDSKBT13\CCStudioc6000Ndsk6713\include"

I» Advanced Options
[» C6000 Linker

"ENCBxCSLAinclude”

. Specify a preinclude file (--preinclude) 8 353

@ Show advanced settings [ 0K ] ’ Cancel ]

Go to Build > C6000 Compiler >Advanced Options>Predefined Symbols\Pre-define NAME
and add CHIP_6713

+v Properties for test

[type filter text | | Predefined Symbols
4 CO000 Compiler -

Processor Options —
Optimization L Configuration: | Debug [ Active | V] ’M.anage Conﬁguratiuns...]

Debug Options
Include Options
Performance Advisor - -
P e O | Pre-define NAME (--define, -D) & w5 8 5L
Advanced Debug Opti jce 613 |
Language Options
Parser Preprocessing C
| Predefined Symbols |
Diagnostic Options
Runtime Model Optior
Advanced Optimizatio
Entry/Exit Hook Opticr
Feedback Options
Library Function Assur
Assembler Options
File Type Specifier
Directory Specifier
Default File Extensions
Dynamic Linking Supp

m

m

.UndeﬁneNAME(——undefine,—U) & %5 3 5l ,G|:

Command Files e
MISRA-C:2004

oo v

] [T + | £

@ Show advanced settings [ 0K ] [ Cancel




Go to Build > C6000 Compiler > Advanced Options > Runtime Model Options
Const access model select far
Data access model select far

'+ Properties for test o [E1] ]

type filter text Runtime Model Options Selzler o ¥
General -

: ~

4 Build =

4 C6000 Compiler Configuration: [Debug [ Active] ~| [Manage Configurtions..| |

Processor Options

Optimization

Debug Options

Include Options Place each function in a separate subsection (--gen_func_subsections, -mo]

Performance Advisor [ Do not reorder floating point operations (--fp_not_associative, -mc)

4 Advanced Options
Advanced Debug Optio|
Language Options

Allow reassociation of sat arithmetic (--sat_reassoc)

I

(| Speculate loads with unbounded address ranges (--speculate_unknown_loads)

Parser Preprocessing O|E Specify maximum disabled interrupt cycles (--interrupt_threshold, -mi)
Predefined Symbols  |=
Diagnostic Options
Runtime Model Option|
Advanced Optimizatior| DAIways use DP-relative addressing for data (ELF only) (--dprel)

Entr}r'fEXItHDD_k Option| Const access model (--mem_model:const)
Feedback Optiens

Aliases: --mem_model:const |pop behavior (--no_bad_aliases, -mt)
Const access model

m

[ Disable software pipelining (--disable_software_pipeling, -muj)

Allow reassociation of FP arithmetic (--fp_reassoc)

Library Function Assurr|
Assemnbler Options

el:data) far -

File Type Specifier o
Directory Specifier Set the size (in bits) of the C/C++ type wchar_t (16,32) (--wchar_t) :] |
Drefault File Extensions [ Prevent loop buffer reload-related error detection (--no_reload_errors)

Dynamic Lm?(mg Suppe] | Specify speculative load byte count threshold or ‘aute’ (--speculate_loads, -mh)
Command Files

[] Compile for breakpoint-based profiling (--profile:breakpt)

MISRA-C:2004 -
e | I ] » DCompi\eforpowerprof\ling (--profile:power) >
o)
C) Show advanced settings oK ] [ Cancel

Go to Build > C6000 Linker > Basic Options

Type in values of 0x400 for stack size and 0x400 for heap size
«« Properties for test [ o == [

type filter text Basic Options Ay v v
General

4 Build o]
a 6000 Compiler n: |Debug [ Active ] '] ’Manage Configurations...]

Processor Options
Optimization

Debug Options |
Include Options tfile name (--output _file, -o) "§{ProjMame}.out”

Performance Advisor tack size (--stack_size, -stack) 0400
> Advanced Options

4 CB000 Linker out sections listed into <file> (--map_file, -m) "§{ProjMName}.map” .

Basic Options
File Search Path
> Advanced Options

Z/C++ dynamic memory allocation (--heap_size, -heap) | 0x400

m

1

@j Show advanced settings oK ] ’ Cancel

= -



Go to Build> C6000 Linker > File Search Path

Add the path of the run time support (rts), chip support libraries (csl) and board support libraries
as follows:

E:\ti\ccsvS\tools\compiler\c6000_7.4.4\1ib\rts6200.1ib

E:\C6xCSL\lib_3x\csl6713.1ib

E:\DSK6713\CCStudio\c6000\dsk6713\lib\dsk6713bsl.lib

(Make the necessary changes in the path depending on where you have the above folders)

Click OK

b Properties for test 3 |
type filter text | | File Search Path Prpyrv I
General
-
4 Build
4 C6000 Compiler Configuration: |Debug [ Active ] '] [Manage Conﬁgurations,‘.]
Processor Options
Optimization

Debug Options T
Include Options Include library file or command file as input (--library, -1}
Performance Advisor “libc.a”
[» Advanced Options
4 CB000 Linker
Basic Options

|» Advanced Options

m

[ Add <dir> to library search path (--search_path, -i) & o 8 'ﬁ| ,&,

"§{CG_TOOL_ROOT/lib"
"${CG_TOOL_ROOT}/include"

Reread libraries; resohve backward references (--reread_libs, -x)
[] Search libraries in priority order (--priority, -priority)

e o e

@ Show advanced settings | oK I [ Cancel
¥ Properties for test = |@ L
| type filter text | | File Search Path Er = It
General
-
4 Build —
4 (6000 Compiler Configuration: |Debug [ Active ] V] [Manage Cunﬁgurations,‘.]
Processor Options
Optimization
Debug Opticns -
Include Options Include library file or command file as input (--library, -1) LERER= R
Perfarmance Advisor ‘libe.a”

"ENtivcesvSitoolshcompiler cG000_7 4 4\lib\rts6200. lib"
"ENCOxCSLNlib_3x\csl6713.1ib"
"E\DSK67134CCStudiot.c6000\dsk6713\lib\dskb713bsl lib"

> Advanced Options
4 (6000 Linker
Basic Options
File Search Path
> Advanced Options

i}

Add «dir> to library search path (--search_path, -i) @ ID @ ‘@\ ,@,
"${CG_TOOL_ROOT}/lib"

"${CG_TOOL_ROOTYinclude"

Reread libraries; resolve backward references (--reread_libs, -x)
|| Search libraries in priority order (--priority, - priority)

[ T R

@ Show advanced settings QK ] [ Cancel




The project window appears as follows after this step

7+ CCS Edit - test/test.c - Code Composer Studio ==
File Edit View Mavigate Project Run Scripts Window Help

M-ER A iE] £ @ i~ = ([ ccaan) =

|-—i}_‘l.l’u_!jc:{_:l Explorer % ] [Debug test E test.c 9 l =g
: : 4 - - =
S = 7 #include “"DSKE713_AIC23.h" //coder. support
4 iw‘z‘ test [Active - Debug]| 8 Uint?2 f==DSK6713_AIC23_FREQ_BKHZ; //set sampling
b ﬁb Binans Q#dE"F:Ene DSKe713_AIC23 INPUT_MIC exeels /N
: 16 #define DSK6713_AIC23_INPUT_LINE @xeell
4 [ Includes 11Uintl6 inputsource=DSK6713 ATC23 INPUT LINE;  // sele
b (B E/CBxCSL/include 12 & = = 3
b (8 E:/DSK6T13/CCStudio/e600|| 13 // * Define global variables here *
b (8 EftifccsvS/tools/compiler/| | 14
gy Debig 15 short sine_table[8] = {@,707,1600,707,8,-707, -1000, -70'
. 16 short gain = 18;
4 (= targetConfigs 174int i = @;
(& DSKE713.ccxml [Active] 18
readme.tit 19 interrupt void c_int11() //interrupt service ro
b [ C6713dsk.emd 26 { o .
b [ c6713dskinit.c @21 ?Et?ut_:sample{galn‘s:l.ne__table[ﬂ)_; "
b [B) C6713dskinith At = | \
| [h] dsk6713_aic23.h
b 8 testc =/ Problems &2 =0
3 @ Vectors_intr.asm 0 errors, & warnings, 0 others
Description ° Resaurce Path
[ & Warnings (8 itemns)
€ [ ] r | ] I | b
nf Licensed I,_g test Writable Smart Insert 30:1

s B

Go to Project > Build project and click

W'« CCS Edit - test/test.c - Code Composer Studio
File Edit View Mavigate IPlojecl Run Scripts Window Help
Fiv @ & v  |OF NewCCSProject B %, CCSDebug (17
CCS Examnple Projects =
o Preject Explorer ¢ o =
Bu?ld Project . support -
4 [ test [Active - Debug jarg  Build All Ctrl+B KHZ ; //set sampling rate
"4 [l Includes Build Configurations | it "
b (8 B/CExCSLYind] Build Working Set » [23 INPUT_LINE; // select LIN
b (1B E:/DSKE713/CC e
b (18 Eftifcesvsitoo) . . here *
4 [ targetConfigs Build Automatically
[ DSK6T13.com Show Build Settings... leae,7e7,8,-707,-1008,-707};
dme.txt
g Add Files...
[ | g C6713dsk.cmd
b [€] c6713dskinit.c [  Import Existing CCS Eclipse Project //interrupt service routine |2
I [h] C6713dskinit.h : 73
2 Import Legacy CC5v3.3 Project * 7Y -
b B dsk6713_aic23.h i ! [i1);
b [g testc Properties
[ [§] Vectors_intrasm T veturn:
253
26
¥
8 void main() // Main Program |
91
@
1// write your main program below
2
3 comm_intr(); //init DsSK, codeg, McBSP i
| « [T » I [ | b
o+ Licensed o




Build finished .out file generated
If any build errors correct them.Warnings may be ignored

'+ CCS Edit - test/test.c - Code Composer Studio [ ==
File Edit View Mavigate Project Run  Scripts Window Help
Wil &~ Wi & o oo o or B %%, CCS Debug 2
0 Project orer € test.c
[t Project Explorer &3 =@ b = m
w i/
= <==={> - 7 #include "DSKE713_AIC23.h" /icoder support =
4 :b‘:‘.j, test 8Uint32 fs=DSKE713_AIC23_FREQ_BKHZ; //set sampling
N %b i S #define DSKE713_AIC23_INPUT_MIC @x@els 1/ =
: 18 #define DSK6713_ATC23 INPUT_LINE @8x8811
4 [l Includes = o =

: 11 Uintlé inputsource=DSK6713_AIC23_INPUT_LINE; // selq
b (= E/CExCSLAinclude 12 3

[ @ E:/DSKAT13/CCStudio/ cb00 12 // * Define global variables here *

b (B EftifcesvS ftools/compiler/|| 14
15 short sine_table[8] = {8,707,1008,767,0,-767,-1060, - 76’

> & Debug : 16 short gain = 18;
4 [= targetConfigs 17 int i = a;
(@] DSKE713.coxml [Active] 18
‘ readme bt 19 interrupt void c_int11() //interrupt service rou
& Console 32 | B HEHEER tB-r3-=0
CDT Build Console [test]
'war;ing #16062-[): build attribute vendor section TI missing in b

"E:\DSKE713\CCStudio\c6@B@\dske713\1ib\dsk6713bsl.1ib<dske713_aic23_registers.obj>":
compatibility cannot be determined

‘warning #16802-D: build attribute vendor section TI missing in
"E:\DSK6713\CC5tudio\c6@08\dsk6713\1ib\dsk6713bs1.1ib<dsk6713_aic23_setfreq.obj>":
compatibility cannot be determined

'Finished building target: test.out’

]

*+** Build Finished ****

1

e Licensed ‘ Writable ‘ Smart Insert ‘ 30:1

Click the Green Debug button in the project window

' CCS Edit - test/test.c - Code Composer Studio
File Edit View Mavigate Project Run Scripts Window Help

wfg L St A~ il e e ([BCcsEa] 7

[ Project Explorer ©3 l [Debug test E test.c &4 l =8
S= v_ 7 #include "DSK6713_AIC23.h" //godeg support
a ;r‘z‘ test [Active - Debug]| 8Uint32 fs=DSK6713_AIC23_FREQ _SKHZ; //set sampling

> 3F Binaries 9 #define DSK6713_ATC23_INPUT_MIC @x@@i1s i

L i 10 #define DSKE713_ATC23 INPUT LINE @xB@ll

4 [ Includes 11 Uintlé inputsource=DSK6713 AIC23 INPUT_LINE; /4 seli
b (= E/CxCSL/include 12 =
1 (B E:/DSK6713/CCStudio/c600)| 13 // * Define global variables here *

i (1 Etifecsv/tools/compiler | 14
15 short sine table[8] = {8,787,1808,767,8,-707,-1080, - 70

Deb
b & De ugc fi 16 short gain = 18;
4 [= targetConfigs 17int i = 8;
%] DSKET13.coxml [Active] 18
readme.txt 19 interrupt void c_int11() /finterrupt service rol
i [# C6713dsk.cmd 26 {
b [g c6T13dskinit.c 21 output_sample(gain*sine_table[i]);
2 22i= i+1; :
b [H C6713dskinith e - | :
[0 dsk6713_aic23.h
b J8 teste = Problems i1 =0
|8 Vectors_intr.asm 0 errors, 8 warnings, 0 others
Description = Resource Path

P} Warnings (8 items)

N i RN 1 | 3
0# Licensed :Lf—f; test Writable Smart Inzert 30:1




This will load the .out file (ie executable code) to be loaded into the DSK.
Now click Run/Resume in the Debug window to Run the code.

To stop execution click Halt .

You can use the above project as a template for further projects. The easiest way would be to
add new source file to the project after removing the existing source file. Another option
would be to start a new project and replicate the steps in this write up which would be a better
and elegant way.
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